Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: 99 Grand Am hard start / no start

 

99 Grand Am hard start / no start 1 year 10 months ago #33854

  • JimO
  • JimO's Avatar
  • OFFLINE
  • 1st Gear
  • Posts: 3
  • Karma: 0
A friend bought this car after it had sat for over 1 1/2 years with out me looking at it first. As you can imagine alot was bad from sitting so long. Brakes being the biggie. The engine is the 3.4 with over 159K. After a week the main head ache turned out to be that the car would stall out and not restart. Cold it would start fine. As it warmed up it became progressivly hard to start. It would start and stall in the run possition. You had to feather the throttle to keep it going. Eventually it would not start at all. Other friends and the owner insisted I change the fuel pump believing the tank was full of rust even though I had 40 psi. The tank was clean inside. I told the owner the old put was still good but he wanted the new one. So I did and the problem continued. No engine codes. When it would not restart I used my clipon stark plug and found no spark. Took off the ICM and had it tested at Auto Zone. It passed all 15 times. Problem continued. Used my Snapon MT2500 still no codes and reading looked good. Long story short I replaced the ICM anyway and the problem was corrected. I beleive that as the old ICM warmed up with the car it began to fail. It had cooled by the time I took it off to test it and did not get as hot during the test. My 96 Old 88 with the 3.8 had the same problem 4 years ago except the Olds just stopped running. Hope this helps someone.
The administrator has disabled public write access.
Advertisement

Re: 99 Grand Am hard start / no start 1 year 10 months ago #33866

  • W00DBar0n
  • W00DBar0n's Avatar
  • OFFLINE
  • 3rd Gear
  • Posts: 180
  • Thank you received: 18
  • Karma: 0
I've heard about that happening a lot with "older" GM cars before, but i didn't think a 99 would have this problem. Something about how they use to build the the ICM/ECM where they just would begin to short after a lot of heat exposure.
The administrator has disabled public write access.

Re: 99 Grand Am hard start / no start 1 year 10 months ago #34592

  • Jotmon1
  • Jotmon1's Avatar
  • OFFLINE
  • 4th Gear
  • Posts: 245
  • Thank you received: 33
  • Karma: 3
Seen it before. ECT bad will cause the ECM to go into limp mode on GM V6 of that era cutting out 3 cylinders by killing the spark and fuel. Taking the connector off the ECT will cure the hard start as a test. If that makes it start then replace the sensor.
2010 Honda, 2003 F150, 2000 Savannah, 1999 SL1, Chevy 454
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.455 seconds