Menu
  • Home

$1500, Still Overheating!

#895328
Katie
Katie
Participant

Wow, the original post was a few years ago I see but alas, I have a 2001 QX4. Coincidentally, it’s a little over 191K on miles and has been periodically overheating during the summer months. Usually I’ll find that I’m a little low on oil or radiator fluid. Now that it’s cooler out, I still swear it sounds like my oil is boiling. Guage isn’t showing overheat but a friend mentioned my motor smelled hot a couple weeks ago too. He’s a hobby mechanic like myself and has some knowledge I do not. I just changed the oil and filter myself about a month ago and I don’t drive much. However, while I haven’t completely read through all the comments, which I realize I really should, I can’t help but find myself wondering if it’s an oil issue? Like the oil pump or sending unit? I do notice an odd smell from my exhaust when I start driving after first start though. Have been wondering if it could be a clogged catalytic converter but haven’t got my lazy but under there at night after a good drive to see if it’s red hot, does that even really work? Anyway, the motor still sounds pristine and I really like the vehicle so would like to repair it if possible. No heat issues inside cabin but there does seem to be a bit of a loss of radiator fluid from time to time and my reservoir doesn’t seem to want to hold anything at all. I’m guessing there’s an unforeseen crack in it somewhere but I haven’t dug in that deep yet. These things are a bit more complicated than I really think they need to be. But I guess that’s just how it goes nowadays, all about the money right?

Loading…