Menu
  • Home
  • Topic
  • 05 Honda Civic EX – Speedometer at Zero While Driving

05 Honda Civic EX – Speedometer at Zero While Driving

Home Forums Stay Dirty Lounge Service and Repair Questions Answered Here 05 Honda Civic EX – Speedometer at Zero While Driving

This topic contains 7 replies, has 4 voices, and was last updated by Kia L Kia L 1 month, 1 week ago.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Author
    Replies
  • #990416
    college man
    college man
    Moderator

    any codes detected?

    #990466
    Kia L
    Kia L
    Participant

    no codes. I also followed the below link to do gauge cluster test. All gauges sweep.

    https://www.civicforums.com/forums/330-electronics/379015-2005-honda-civic-ex-speedo.html

    #990503
    college man
    college man
    Moderator

    If you have a scanner, plug it in and see if you can read the MPH. if no then replace the vss.

    #990606
    kiemeo lili
    kiemeo lili
    Participant

    no codes. I also followed the below link to do Melbourne escorts near me gauge cluster test. All gauges sweep.

    #991312
    Kia L
    Kia L
    Participant

    I could read MPH using the scanner. Last weekend I just replaced the VSS, but I still have the same issue. Any suggestions?

    #991316
    Nightflyr *
    Richard Kirshy
    Participant

    If tyhe cluster gauge is functional and replacing the sensor didn’t fix the issue.
    Suggest you check / test the wiring from the sensor to the gauge.

    #991353
    Kia L
    Kia L
    Participant

    One thing I forgot to mention is that, It works every now and then. Maybe 6/10 works. Sometimes the needle is getting stuck. Just curious, does it require to remove the instrument cluster when checking and testing the wires from vss to the gauge?

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Loading…