Menu
  • Home
  • Topic
  • 1993 Chev S10 2.8L no start even after new timing chain

1993 Chev S10 2.8L no start even after new timing chain

Home Forums Stay Dirty Lounge Service and Repair Questions Answered Here 1993 Chev S10 2.8L no start even after new timing chain

This topic contains 3 replies, has 2 voices, and was last updated by Nightflyr * Richard Kirshy 1 year ago.

  • Creator
    Topic
  • #894424
    William
    William
    Participant

    Hello all,

    This S10 stopped on the road and never cranked up again. Compression test gave up to 30 PSI on all cylinders. So I replaced the timing chain and cam/crank sprockets. Old chain was quite loose and of course the scoring and wearing as you’d expect. Only the truck still does not start. It just spins. I will attach a video here of before the timing chain but the behavior after the repair is quite identical.

    I felt no resistance turning the engine by hand, I’m just a little iffy on whether the issue was the chain or not vs. an ignition component. There is spark and there is fuel.

    I have a thread on 2CarPros.com about this but sometimes I get mixed information/signals from them so I’m searching for other opinions

    Hopefully this video will show up https://www.2carpros.com/images/question_images/282693/video.mp4

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #894426
    Nightflyr *
    Richard Kirshy
    Participant

    Try a leak down test to locate the compression loss.

    #894427
    William
    William
    Participant

    Okay, the compressed air would not hold and just came right out of the tailpipe with the smell of fuel

    #894428
    Nightflyr *
    Richard Kirshy
    Participant

    if you confirmed that both valves were closed on the cylinder(s) when you tested.
    You may have either :
    Damaged valve, seat or both.
    Cracked head
    Cracked block

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Loading…