Menu
  • Home
  • Topic
  • 1993 f150 cuts out and looses power when warmed up and underload

1993 f150 cuts out and looses power when warmed up and underload

Home Forums Stay Dirty Lounge Service and Repair Questions Answered Here 1993 f150 cuts out and looses power when warmed up and underload

This topic contains 2 replies, has 2 voices, and was last updated by Jason Nesmith Jason Nesmith 9 months, 1 week ago.

  • Creator
    Topic
  • #895539
    Jason Nesmith
    Jason Nesmith
    Participant

    I am trying to solve a problem with my son’s 93 f150 with 5.0. When it is cold it runs great without any issues. However when it warms up and is under a load it’ll pop back through the intake and loose power almost to the point that it’ll die. If you slide it in neutral and kill it and restart it runs fine again.

    We have replaced the fuel pump, fuel filter, plugs, wires, coil pack, ECM, PCV valve….. Any ideas?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #895551
    Billy
    Billy
    Participant

    Compression test. If an intake valve is not sealing properly, that’ll give you a backfire. Also check ignition timing.

    #895557
    Jason Nesmith
    Jason Nesmith
    Participant

    How would either of these two things be reset by cycling the ignition switch? I would think that either compression or timing would either be right or wrong and not be changed by the cycling of the ignition switch. Just curious.

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Loading…