Menu

2002 Sunfire 2.2l SFI

This topic contains 7 replies, has 2 voices, and was last updated by Nightflyr * Richard Kirshy 8 months, 1 week ago.

  • Creator
    Topic
  • #895627
    Conrad Hutchings
    Conrad Hutchings
    Participant

    hello there i have a 2002 Sunfire and the cluster and everything works great on it it is just the LCD screen where it shows your trip quit working just wondering if there is away to replaces it or something to make it work again

    Thanks Huchters358

Viewing 7 replies - 1 through 7 (of 7 total)
  • Author
    Replies
  • #895628
    Nightflyr *
    Richard Kirshy
    Participant

    1 You can check the connections on the back of the cluster for damage or corrosion.
    2 You can remove the cluster and check for any cracked / fractured solder joints then attempt to re-flow the solder.
    3 You can remove the cluster and send it to United Radio and have it serviced / repaired

    #895705
    Conrad Hutchings
    Conrad Hutchings
    Participant

    thank you so much for the help it as a burnt out light bulb on the board do you now how hard it is to replace the bulb on the board

    Thanks Huchters358

    #895707
    Nightflyr *
    Richard Kirshy
    Participant

    The gauge illumination bulbs appear to be a twist lock design.

    #895754
    Conrad Hutchings
    Conrad Hutchings
    Participant

    I pulled the cluster apart and they are not they are soldered onto the board

    #895756
    Nightflyr *
    Richard Kirshy
    Participant

    If that be the case…
    You’ll need to un-solder them and re-solder replacements in.

    #895776
    Conrad Hutchings
    Conrad Hutchings
    Participant

    ok not that hard to do any recommendations on light bulbs to put back into it

    Thanks Huchters358

    #895777
    Nightflyr *
    Richard Kirshy
    Participant

    OEM stock replacements

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Loading…