2002 Toyota RAV4 Ignition problem

Home Forums Stay Dirty Lounge Service and Repair Questions Answered Here 2002 Toyota RAV4 Ignition problem

This topic contains 7 replies, has 3 voices, and was last updated by Avatar hondaguy453 1 year, 3 months ago.

  • Creator
  • #892558

    I’m trying to revive a Rav4 that has had some random work done on it by the previous owner to try and get it running again. But I’m getting stuck.

    • Compression on all 4 cylinders is ok 155-157
    • Fuel pressure on the rail appears ok at about 47 psi with no signs of leak down (couldn’t test long due to fitting) based lead down on pressure remaining in the system overnight.
    • I was able to get spark on all 4 coils but now I’m not
    • I see 12V and 5V signal on the coil lines but one line (not ground) is sitting at 0V while cranking and the 5V doesn’t seem to change — using a volt meter not a scope

    – I’ve put in known good coils and plugs from another car
    – I replaced the fuel pump (wasn’t working) and drained the fuel tank and put in fresh gas
    – I’ve inspected all the wiring and fittings physically and they look ok
    – The previous owner seems to have swapped out many of the sensors, coil packs, cam sensor and O2 sensor. I swapped in coils and plugs that I know to work from another car.
    – At one point the previous owner probably tried using another ECU from a 4×4 RAV. I don’t know what issues this might do, but I feel like the immobilizer would have prevented a direct swap from working without using a different key. I believe the ECU in it now is the original.

    Using a ODBII while cranking I see the following:

    Coolant 25C
    MAF 2.8g/s
    Revs: 250 rpm
    load: 59.6%
    O2S1Eq: 1.0
    STFT1: 0.0%
    intake: 26C
    Timing Adv: 5 deg
    Throttle: 13.7%

    I’ve had a variety of problems while debugging this car. Before I found the bad fuel pump I was able to get it to spark and kick using starting fluid and I also used an in-line spark probe (simple light) and saw it lighting. After changing out the fuel pump, checking compression and fuel pressure I can’t seem to get spark again.

    So I’m stuck now on the possibilities:

    – The only code is P0758 – transmission shift solenoid B electrical
    – Currently I’m not seeing a spark, but coils have 12V and 5V signal (I’m not sure my multi-meter would indicate ignition pulses or not — but it sits pretty solid on 5V and 0V for the two inner wires besides the ground and 12V.)
    – Is the immobilizer causing a problem? I only have the key not the FOB. The drivers door lock seems to behave a little strange so I’ve tried locking and unlocking with both drivers door and back door. I don’t know how to tell if this is immobilized or not. The fuse is present in the fuse box. I pulled it but didn’t see any change while cranking. I would not be surprised if there is something intermittent with the door mechanisms.
    – I’ve tried shorting pins 4 and 13 on the OBDII connector for 30 minutes with ignition on to reset the ECU but that didn’t change anything.
    – I’m not sure how to tell if the immobilizer is preventing ignition or not (I think the 2002 RAVs – 2nd GEN. will crank but not fire when immobilized, not I’m not sure)
    – What is a good next step to try?

    Any help would be really appreciated. Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Author
  • #892566

    When you replaced the fuel pump you removed the ground cable from the battery, right? Is this when you noticed you longer had spark? If that is the case, you could have reset the security system which is, like you said, preventing spark. You could find the module and disable it, then try to start it.


    Thanks for the help. Yes I remove the negative often while I’m working on it and over night.

    I’ve pulled the jumper fuse in the fuse box if that’s what you mean by disabling it but I didn’t notice a difference. I also tried toggling the drivers door lock which doesn’t always work and the rear door lock with the chip key.

    It’s not clear to me if the immobilizer is on or off and I don’t know how to check for it.

    Its me

    Check to ensure your crank position sensor is sending a signal…. On this year RAV4 you should see the Tachometer move when you crank the engine. If it is not moving, trace the crank position sensor line and ensure there are no breaks.

    When you turn the key, the Fuel pump will run for a few seconds (to prime the pump) and will and should give you a good fuel pressure reading… After that if it does not get the crank signal it will turn off the voltage to the fuel pump…

    So you are probably getting spark, (hence why you can start it with starting fluid) but are not getting a consistent fuel supply.

    Now you mentioned you are not getting a spark… That is controlled by the signal from the Cam position sensor… Check all those wires.

    If I were to have this car in my shop, I would hook my labscope up to the crank and cam positions sensors and check them as well as ensure their wiring was not an issue.

    Good luck



    Thanks Karl. I’m guessing the cam sensor is working since I see the rpms jump around on the ODBII readings. On the crank sensor: The tach needle does lift up while cranking but there’s only a very slight bounce. So small that I’m not sure if I’m just fooling myself.

    I’ve traced the wires and they seem fine so I’ll try to probe them. I don’t know why I was able to measure Sparks on all 4, able to get it to kick with starting spray but after changing the pump out it seems to have stopped working. This is why I suspected the immobilizer but I’ll step back and see what else I can find.


    It’s been awhile but I haven’t gotten much further. I have a second running RAV4 (same year) that I can swap parts with. Here’s where I’m at

    • Got an advanced OBDII reader and found the immobilizer was triggered for some reason.
    • Swapped out the ECU from my running RAV4 to this one. Covered the chip key with foil and used the other key from the running RAV4 to trick the immobilizer while turning the original key. This works well, no security light blinking and OBDII shows good and I see sparks
    • Still won’t try to fire without starting spray (which doesn’t work 100% of the time either??)
    • Swapped out the fuel regulator with a working one, while off the rail I turned the engine and saw ok fuel flow
    • Fuel rail looked dry, so tried new regulator but no change. Took it off and rail still looked pretty dry.
    • Removed and cleaned rail and injectors. Tested each injector with 12V and all clicked.
    • Tried starting car with injectors pointed up. All 4 spit fuel in what looked like a reasonable starting pattern. It was a light sort of spitting not the high pressure burst that I’ve seen on testers via youtube

    So with that going on, I reconnected the fuel rail hoping maybe the cleaning cleared them out, but no change. I hit the air intake with some spray again and it tried to fire up. I’m pretty confused at what I should do for a next step.

    1. Could there be something wrong with all the injectors?
    2. Should I recheck the fuel line pressure? I’ve put in a new pump as well as tried swapping a known working pump.
    3. Is there something on the throttle body that could be causing a problem because it doesn’t always try to fire with the starting fluid for some reason?

    Any other ideas? Thanks!


    Just thought I’d close this out. Turns out the new fuel pump I bought to replace the failed one was faulty. It pumped fuel but the line pressure was too low. Once I found it was was too low, I was able to replace it and get the fuel pressure up enough for consistent firing and it’s finally running again.

    Thanks for all the help on this one.


    I’m sorry it took so long to respond. I pop on whenever I get a chance. I’m glad you were able to figure it out!

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.