Menu
  • Home
  • Topic
  • 2003 honda accord right turn signal issues

2003 honda accord right turn signal issues

Home Forums Stay Dirty Lounge Service and Repair Questions Answered Here 2003 honda accord right turn signal issues

This topic contains 6 replies, has 3 voices, and was last updated by Avatar Andrew Phillips 5 years ago.

  • Creator
    Topic
  • #668610
    Avatar
    mike
    Participant

    hi there everyone well i drive a 2003 accord and suddenly the right turn signal stopped working and its been hell and haven’t been able to get it fixed i changed all bulbs, fuses ,relays ,turn signal switch , hazard switch, so it just stopped working so i had the left side just working so i decided to take it to the Honda dealer they spent 5 hours working on it and still couldnt figure it out , one hazard works when i hit the hazard switch only the left side will come on and the whole right side is dead even in the cluster with the little green arrow doesnt even work thanks and any help would be appreciated

Viewing 6 replies - 1 through 6 (of 6 total)
  • Author
    Replies
  • #668628
    Avatar
    Andrew Phillips
    Participant

    This may be quite the booger to figure out. Below are the wiring diagrams. The issue may be a fault in the combo switch itself, the combo switch control unit, the relay control module, or multiplex control unit (MICU).

    Attachments:
    #668661
    Avatar
    Mike
    Participant

    Does this lamp do double duty as a running light whenever the Park/Headlight switch is activated, or is it supposed to be illuminated only when the turn signal or hazard functions are selected? If it’s supposed to function as a running light, does it illuminate at all when the headlight switch is in the Parking Light or Headlight position?

    Have you checked ground “G201” in the diagram cap269 provided. It looks like the right turn signal indicator in the cluster shares the same ground.

    #668665
    Avatar
    Andrew Phillips
    Participant

    [quote=”Evil-i” post=141434]Have you checked ground “G201” in the diagram cap269 provided. It looks like the right turn signal indicator in the cluster shares the same ground.[/quote]
    The dash indicators are actually connected to ground G501. The reason I did not post that I suspect a bad ground is because for the front T/S, rear T/S and dash light requires three separate grounds. It is more likely a control issue than a ground issue in that case. If G501 were at fault, the left side wouldn’t work either.

    Attachments:
    #668933
    Avatar
    mike
    Participant

    thanks for the reply but i forgot to mention that the left turn signal worked before i took it into the dealer ship and when it came out it didnt work at all the only thing that works is the left hazard light when i push the hazard switch . I replaced the turn signal switch in the steering column and hazard switch , and the turn/hazard relay and i checked the grounds in the trunk they all seem to be fine

    #669241
    Avatar
    mike
    Participant

    i replaced the MICU problem solved thanks again

    #669246
    Avatar
    Andrew Phillips
    Participant

    Excellent. Glad we could help 🙂

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Loading…