Menu
  • Home
  • Topic
  • 2006 Honda Odyssey, no start, tried everything

2006 Honda Odyssey, no start, tried everything

Home Forums Stay Dirty Lounge Service and Repair Questions Answered Here 2006 Honda Odyssey, no start, tried everything

This topic contains 1 reply, has 1 voice, and was last updated by Nunya Business Nunya Business 5 months, 1 week ago.

  • Creator
    Topic
  • #989079
    Nunya Business
    Nunya Business
    Participant

    Backstory, was sold a mismanufactured timing tensioner pulley that caused a timing belt failure. Bent 2 valves. I pulled the head, replaced valves, new timing belt kit, now have compression on all cylinders.

    Unfortunately when putting the throttle body back on I didn’t have the negative terminal pulled and I touched my ratchet to the positive battery terminal when tightening a nut on the throttle body. Got a code for the throttle body, replaced that and now have no codes and throttle works. I also got a coolant temp high code which seems to be from my VCM tuner getting fried which sits inline to the coolant sensor. Disconnected this and the engine reads the correct coolant temp now.

    At the moment I have no coil pack or fuel injector impulses
    List of tests done:
    -OBD2 scan tool shows engine getting RPM signal, throttle movement, intake air temp, coolant temp, o2 voltages etc. Everything I’d expect.
    -All relays and fuses verified functional with volt meter
    -Fuel pressure verified
    -ECU swapped with matching serial number and keys/vin added to ECU. Immobilizer light goes off correctly
    -For fun sprayed in starting fluid, no start
    -Swapped cam position sensor

    I don’t know what else could be wrong. I don’t have a wiring diagram from the ECU to be able to test for a broken wire although I’d doubt that since its all injectors and coil packs not getting an impulse.

    Are there any separate modules that could be causing an issue I don’t know about?

Viewing 1 replies (of 1 total)
  • Author
    Replies
  • #989081
    Nunya Business
    Nunya Business
    Participant

    I should clarify that the engine cranks but does not fire.

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.

Loading…