Menu

94 accord EX cuts off when stopping

Home Forums Stay Dirty Lounge Girls in the Garage 94 accord EX cuts off when stopping

This topic contains 20 replies, has 6 voices, and was last updated by Tonya Tonya 3 years, 11 months ago.

  • Creator
    Topic
  • #863895
    Tonya
    Tonya
    Participant

    I have a 94 Honda Accord EX. It runs beautifully. Every time I come to a stop or get ready to turn it shuts off. It starts right back up after. Replaced just about everything. Idle air control valve, distributor unit, fuel pump, fuel filter, IAC valve, ERG valve, main relay, ignition switch and harness, PCV valve, engine coolant temp sensor, O2 sensor, map sensor, charcoal canister and vent solenoid, throttle position sensor, fuel pressure regulator, New rebuilt ECU, fuel sending unit, I had a rebuilt transmission one year ago. Can anyone help me fix this issue? Any suggestions are greatly appreciated. I see a lot of older Honda owners are going through and have gone through this. I had it in the shop for three weeks and they’ve tested everything or so they said and can’t find the issue.

Viewing 5 replies - 16 through 20 (of 20 total)
  • Author
    Replies
  • #865413
    Tonya
    Tonya
    Participant

    I’ve noticed that many people state their problem but never come back and post what the actual fix was. I’ve had the car at the Honda dealership for two weeks now. They’ve so called narrowed it down. Honda said its the fuel injectors. Im having them replaced by Honda and the car should be finished this week. They had to order the injectors. I’ll definitely keep you posted. Thanks again for EVERYONES help.

    #867156
    Ivan
    Ivan
    Participant

    Did you get the problem fixed? I cant seem to find a date for when stuff is posted on here

    #867167
    Tonya
    Tonya
    Participant

    No I didn’t. Honda said it was the fuel injectors. They replaced them and it didn’t fix the problem. Going to change the fuel pump harness this week. I also found that the fuel pressure regulator on my car isn’t for my 94. It’s for a 97. I can feel and hear the air at the hose. The hose fits a little big. Going to replace that too this week. I’m also going to replace the check valve going to the brake system. I’ll post again at the end of the week. Do you have any suggestions? Thanks!!!

    #867492
    Tonya
    Tonya
    Participant

    UPDATE!! I finally got the car to stop shutting off. After 3 new fuel pumps from advanced auto I bought an OEM used fuel pump and fuel pump harness wire set off eBay. Installed them and the car does not shut off anymore. I only have one problem now. When I start the car and put it in gear it wants to take off by its self. It’s idling really high. I suspect it’s a vacuum leak because I have a new IAC valve. My ABS brake light is on now so I’m thinking it could be a vacuum leak in the booster or the check valve. The worst part is over. I’ll keep you posted!☺️

    #869082
    Tonya
    Tonya
    Participant

    The vacuum issue has been fixed. It was the ERG vacuum control solenoid. My abs light was on because of a faulty brake sensor. I hope this post helps someone in the future. Until next time, so long. A huge thank you to everyone that took the time to help me.

Viewing 5 replies - 16 through 20 (of 20 total)

You must be logged in to reply to this topic.

Loading…