Menu
  • Home
  • Topic
  • 96 Accord, no turn signals or hazards

96 Accord, no turn signals or hazards

Home Forums Stay Dirty Lounge Service and Repair Questions Answered Here 96 Accord, no turn signals or hazards

This topic contains 2 replies, has 3 voices, and was last updated by Sam Roodman Sam Roodman 5 months, 2 weeks ago.

  • Creator
    Topic
  • #987588
    Jennifer Larson
    Jennifer Larson
    Participant

    Hi, I just got a 96 Accord for my daughter to take up to college. The guy I bought it from said it had been stolen 2 years ago, and they took the stereo, but nothing else and he got it back. When they took the stereo, they broke the trim above it, and that’s where the hazard lights switch is. so the switch is gone, but the wire harness is still there. He said the turn signals didn’t work after that. I got a hazard switch from the junk yard when I got the combo switch. When you push either switch, there is no response – no clicking, buzzing, indicator lights, nothing. I figured this would be an easy fix, and replaced the combo switch, but no results. I checked the fuses, and replaced a couple, but no change. replaced the relay, nothing. I would appreciate any ideas.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #987628
    Dustin Wendorf
    Dustin Wendorf
    Participant

    Check the fuse for small lights in the passenger side fuse panel if im correct ..

    #987886
    Sam Roodman
    Sam Roodman
    Participant

    Turn signals nor hazards will work without the switch. Honda passed all this functionality through it making it mandatory. I would suggest getting a fsm or visiting the local library to gry a schematic and check for things that should be hot. I believe etcg as well as many others have videos for testing fuses, relays and switches

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Loading…