Menu
  • Home
  • Topic
  • Cranks, no start, no ignition run functionality

Cranks, no start, no ignition run functionality

Home Forums Stay Dirty Lounge Service and Repair Questions Answered Here Cranks, no start, no ignition run functionality

This topic contains 2 replies, has 2 voices, and was last updated by Joe Bush Joe Bush 1 week, 4 days ago.

  • Creator
    Topic
  • #984866
    Joe Bush
    Joe Bush
    Participant

    As stated, my prelude will crank but won’t start. All functions of ignition run is not working, not even dash lights and I cannot find any fuses that a fried. I first thought this would be a main relay problem but people with failed main relay have said that they still have dash lights, wipers, etc. Then I thought maybe ignition switch but a post on this site said that the car would fire even if the run position was not working. Am I looking at an ECU problem?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #984867
    Lucas Desjardins
    Lucas
    Participant

    Vehicle will not start if the ignition switch is faulty. I have been down this road before first make sure you here the fuel pump kicking on if so use a test light and hook it to ground turn the ignition on and check for power at the switch. I replaced a lot of ignition switches on these vehicles

    #984869
    Joe Bush
    Joe Bush
    Participant

    I’m under the understanding that turning to the crank position should close the main relay even if one of the contacts in the switch is faulty, so it should at least splutter and fire even if one of the contacts isn’t working.

    I will check with a multimeter as soon as I can find mine but I would love some confirmation of this (or even better if you can tell me this isn’t the case and that both need to work).

    Thanks for the reply

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Loading…