Menu
  • Home
  • Topic
  • honda civic 1.5vtec, cranks but no start

honda civic 1.5vtec, cranks but no start

Home Forums Stay Dirty Lounge Service and Repair Questions Answered Here honda civic 1.5vtec, cranks but no start

This topic contains 0 replies, has 1 voice, and was last updated by Sakke Rele Sakke Rele 1 year ago.

  • Creator
    Topic
  • #895114
    Sakke Rele
    Sakke Rele
    Participant

    Hi!
    I have problem with my honda civic. Engine is 1.5vtec, year 1996. Problem is that the car wont start. It cranks but has no power to fuel pump and no spark. It just died one day when I was driving normally. I have checked all fuses with volt meter and everything is fine, I have tried jumping power to fuel pump from main relay connector and it primes fine and main relay does have good looking solderings, also checked ignition switch wiring and immobilizer relay and everything seems fine. I have used volt meter to measure every cable in the car that might cause issue and no luck. Checked all grounds and they are good. Engine light stayed solid when I last saw it as it doesnt light up anymore. Immobilizer light is blinking and it goes off as I turn ignition on but engine light wont come on. This started today when I tried to find the problem and double checked all fuses. Almost every simple thing that have worked to someone else I have already tried. Did my ecu just go bad while driving or can it be something simple?

You must be logged in to reply to this topic.

Loading…