Menu
  • Home
  • Topic
  • My B series wont start unless I unplug the MAP sensor

My B series wont start unless I unplug the MAP sensor

Home Forums Stay Dirty Lounge Service and Repair Questions Answered Here My B series wont start unless I unplug the MAP sensor

This topic contains 0 replies, has 1 voice, and was last updated by Vincent Erb Vincent Erb 4 months, 1 week ago.

  • Creator
    Topic
  • #989767
    Vincent Erb
    Vincent Erb
    Participant

    Hey yall, I recently replace the timing belt, water pump, tensioner, crank and cam seals etc on my OBD0 B16A.

    after the belt change, I started the car up and it ran okay, but I decided it would be wise to set the distributor timing. With that in mind, I jumped the 2 pin connector and started adjusting the timing.

    but for some reason, after finishing, my idle was erratic and surging, and the car would cut out if you gave it too much gas.

    so we checked, double checked and triple checked the mechanical timing, and tried advancing or retarding the ignition timing, all to no avail.

    then I unplugged the MAP and the car ran basically fine, just somewhat rich (due to being in limp maybe?).

    anyway, fast forward to about a month later, and the car wont even start unless the MAP is unplugged.

    So I have a feeling that my issue is either fuel delivery or timing, but I checked my timing religiously and I’m 99% sure its correct.

    has anyone ever had an experience like this?

    ECU is a stock pr3, jdm first gen B16A engine in a CRX si.

You must be logged in to reply to this topic.

Loading…