Menu

Suspected Transmission Failure

Home Forums Stay Dirty Lounge Service and Repair Questions Answered Here Suspected Transmission Failure

This topic contains 3 replies, has 2 voices, and was last updated by Jake F Jake F 4 months, 3 weeks ago.

  • Creator
    Topic
  • #988308
    Seth R
    Seth R
    Participant

    Hello. I have an 08 Ford Escape. Over the past few months, it’s had a little slippage when going from 2nd to 3rd. Nothing huge, but certainly noticeable. Now, all of a sudden, it needs to hit 3500 rpm before it’ll shift to 3rd and doesn’t seem to shift again after that at all. When I got it out on the highway, I was 3k rpm at 60mph. I revved up past 4k but couldn’t get that final shift anymore. I’m going to replace the throttle body when I get the part, but I’m starting to suspect that my transmission/clutch is shot. Any thoughts?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #988309
    Seth R
    Seth R
    Participant

    I will also mention that the yellow wrench light indicating powertrain malfunction or an electronic throttle body system malfunction came on when it started to not shift until 3500 rpm. Research around that is why I’m going to try the throttle body first.

    #988316
    Seth R
    Seth R
    Participant

    2nd update after some more testing. It actually seems to not shift into 2nd at all. The first shift is the one that goes to 3500 rpm and I believe it’s to 3rd as in that gear, I can drive up to around 35mph or so comfortably. It did shift once today normally but after that and coming to a stop again, the yellow wrench came back on and it went back to having the shifting issue.

    #988324
    Jake F
    Jake F
    Participant

    Yeah, it’s on it way out. You can throw some Lucas branded fluid. Try to keep it running tho…maybe it’s all in your head now that marijuana is legal in Arizona

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Loading…