Menu

Toyota Rav4 Water Leak

Home Forums Stay Dirty Lounge Toyota Rav4 Water Leak

Tagged: 

This topic contains 0 replies, has 1 voice, and was last updated by Glen G Glen G 4 months, 2 weeks ago.

  • Creator
    Topic
  • #990605
    Glen G
    Glen G
    Participant

    We have a 2015 Toyota rav4, it has a water leak that comes through the overhead controls console for the sunroof.
    Long story short, after several inspections, the source of the leak cannot be found either by Toyota or a local water leak detection company.
    I suspect it has something to do with a replacement windshield the car has from the prior owner. We bought the car used in 2018.

    Video of leak https://www.youtube.com/watch?v=wYVmT-Af8JM (at about 30 seconds).
    Pics: https://drive.google.com/drive/folders/1tU3ej7mJMOy3yxkjsSppRutAasXfBCdo?usp=sharing

    Background:
    In December 2020, we drove in our alleyway, went up hill and the water started coming through the overhead controls of the sunroof.
    We brought the car to Toyota and they said a drain tube had a kink in it.
    Shortly thereafter, it leaked again in the same way.
    We brought it back to Toyota, they sent it to a water leak company, who discovered a seal had gone bad for one of the roof racks. Seal replaced.
    Fast forward to February, parked and drove in rain, for several weeks no issues.
    Late February, when we had light snow, we drove the car the same day and the water came back through in the same place, though not as much.
    After that, I noticed (although it could have always been there) the windshield seal/rubber didn’t look quite right, especially on the passenger side and started suspecting the source of the leak was the windshield.
    Toyota and the water detection company both inspected again and can’t find a leak. Toyota did however point of the bottom of the windshield has a place where the seal is lifted.
    I ran water directly into the front drains with a funnel and the amount I put in is the same exact amount that flows out, I measured it.
    I ran water into the areas where windshield seam looks funky and the water comes out the drains. I did not measure the in/out.
    We are at the end of our ropes here. Please help.
    Now we are here 🙂

You must be logged in to reply to this topic.

Loading…