Fluids after sitting for a loooong time

  • Jonnygirl
  • Jonnygirl's Avatar Topic Author
  • Offline
  • 1st Gear
  • 1st Gear
  • Just lookin for answers. :-)
More
2 years 3 months ago #187499 by Jonnygirl
Fluids after sitting for a loooong time was created by Jonnygirl
Hey gang,
I'm posting this again cuz Idk if everyone checks the chick's department. Lol
Ok I'm pretty sure I already know the answer but I want some clarification from guys who know what the hell so.. I've got a 64 Chevy 4x4 with a crap is it a 283 or 327? Brain fart sorry I don't think that matters much for this ?. Anyway it's been sitting for like 10 yrs & I've got to move it from this spot cuz the property owner is saying she's gonna put it on the street by Monday morning & she could very well do so seems how it's got a switch that starts it without a key. I plan to get there first & do all the necessary things to get it ready to roll. But ya never know what she's gonna do the way she's acting lately so I want to know how much COULD the damage be if she were to start it without checking any of the fluids? The gas could be kerosene by now right? & god knows about the others. Thanks I'd appreciate any input .
Take care
Jonny

Jonny

Please Log in or Create an account to join the conversation.

Advertisement
More
2 years 3 months ago #187528 by 451Mopar
Replied by 451Mopar on topic Fluids after sitting for a loooong time
After 10 years I would think the battery is dead.

Fluid wise, it is going to be bad. Fuel may have evaporated, and left deposits and rust in the fuel tank and lines. I'd be worried about the brake system too.
Usually transmission, and gears will be OK as long as no water got in.
The engine could have several issues. I would almost expect radiator fluid leaks it it has fluid. I had core plugs rust out of a car that sat for several years.
Engine oil condition will depend on how much water/humidity got in the engine, but worse is all the parts where the oil has ran off and may have allowed rust to form inside the engine. You could pull the distributor and spin the oil pump to pre-lube the engine, but there will still be parts that won't see oil until the engine starts (like piston pins.)
The following user(s) said Thank You: Jonnygirl

Please Log in or Create an account to join the conversation.

More
2 years 3 months ago #187791 by WyrTwister
Replied by WyrTwister on topic Fluids after sitting for a loooong time
Yes .

Drain & replace as many fluids as you can . Look for leaks .

Hopefully field mice have not chewed up the wiring . Look for any visible damage & splice / repair as best as you can .

Take a good battery with you . Be prepared to prime the engine .

You can only do what you can do with what you have to work with .

Best of luck to you . :-)

God bless
Wyr
The following user(s) said Thank You: Jonnygirl

Please Log in or Create an account to join the conversation.

  • Jonnygirl
  • Jonnygirl's Avatar Topic Author
  • Offline
  • 1st Gear
  • 1st Gear
  • Just lookin for answers. :-)
More
5 months 4 days ago #201945 by Jonnygirl
Replied by Jonnygirl on topic Fluids after sitting for a loooong time
Hey there,
Yep it's been a long time since my post I know but here I am again , same situation only now I've gotta move it from different location & my trucks condition is a little more familiar to me.. sorta. I'm not sure if the gas was evaporated or not but the smell wasn't quite gasoline but it wasn't exactly kerosene either. But I was by myself , on a time limit & yeah u nailed it. Had to do with what I had, that includes knowledge in my brain. So I just added new gas, water and oil. It wouldn't start & still wont. A friend got it to start by running a hose into a gas can rather than through the system I guess idk I wasn't there. But we know there's spark just not gettin fuel to carb. Also when I first lifted the hood I noticed the air cleaner was missing. I later found it in the back rusty as hell but present. I have no idea who or WHY someone would've taken it off. It was likely some idiots who were visiting the tenants of where I had it, they'd also used it for target practice with their BB gun. Yeah it's pretty bad Also I've got no headlights for some reason. Even with a brand new battery. I do have dash lights but that's it. So I assume the wiring has been chewed. As it was clear that rats & mice had been in & out of it. So what would u recommend I do or try to at least get it started? Sea foam engine treatment maybe? It was towed improperly I might add by someone I know who was saving it in a pinch from being towed by the city to where it's at now. I just need to hear from someone who KNOWS rather than THINKS They know. U follow me? I don't need no more problems with it. It was just fine when I drove it there years ago so I see no reason it can't drive again. Thanx for your help.

Jonny

Jonny

Please Log in or Create an account to join the conversation.

More
1 week 2 days ago #203175 by ferd
Replied by ferd on topic Fluids after sitting for a loooong time
i would have it towed. Doubt it will be a quick fix.

Please Log in or Create an account to join the conversation.

Advertisement
Time to create page: 0.252 seconds