auto parts shop says starter is good. my tests say it ain't

  • OliverClothesOff
  • OliverClothesOff's Avatar Topic Author
  • Offline
  • 1st Gear
  • 1st Gear
More
1 month 1 hour ago #202988 by OliverClothesOff
Hi friends,

I have a 1994 Nissan D21 hardbody pickup with a 2.4 4cylinder KA24E engine with a stick shift 5 speed. I have a unknown brand starter motor that I bought for it two years ago. I was getting it tested at O'Reily's and I personally witnessed it pass the test six times so I take the starter motor back home, hook it up to my battery with jumper cables to see if it runs properly like it did at the O'Reily's place and it doesn't. The bendix will spin over good but it will not extend out. It did it once out of like probably 10 attempts. This was same problem it had when I tested it in my garage before I took it to O'Reily's.

What's going on with it? Do I need a new one? Am I testing it wrong?


Thanks,

Craig the car noob

Please Log in or Create an account to join the conversation.

Advertisement
More
4 weeks 2 days ago #202989 by relative4
It is supposed to spin AFTER it extends. Are you saying it spins without extending? If so, your wiring is wrong.

Please Log in or Create an account to join the conversation.

  • OliverClothesOff
  • OliverClothesOff's Avatar Topic Author
  • Offline
  • 1st Gear
  • 1st Gear
More
4 weeks 2 days ago #202991 by OliverClothesOff
i don't know because at the shop it did both so fast i couldn't tell. for the sake of the discussion, I will say yes. However, i hooked the starter up to my battery via jumper cables, grounded the starter to the engine by laying it on top of the metal valve cover and would 'touch' the positive terminal on the starter with the positive battery cable and while the motor would spin, the bendix would not extend....it only did it once out of probably 10 of my attempts to supply power to it. I may have not just grounded the starter well. Do you think that was the problem?

Please Log in or Create an account to join the conversation.

More
2 weeks 4 days ago #203085 by relative4
You have no doubt long since resolved this, but amusingly enough, I had the exact same situation today with an '05 Sienna. Turned out to be a bad starter.

Please Log in or Create an account to join the conversation.

Time to create page: 0.235 seconds