engine rattle on start up

  • DBSoccer
  • Topic Author
  • Offline
  • 1st Gear
  • 1st Gear
More
4 months 1 week ago #203068 by DBSoccer
engine rattle on start up was created by DBSoccer
1997 Toyota Rav4 with 2.0L 4 cylinder. Recent overhaul. When the cars has sat for a day or two the engine will rattle at start up for a few seconds and the "oil pressure" light will remain on for longer than I'd expect. Oil pump was new (OEM) and the oil pressure is as I'd expect for a new pump, etc. If I shut things off and restart the light goes out almost immediately (as I'd expect) and there is no rattle. When the engine is fully warmed up it sounds great. By rattle I mean like valve train noise or rod bearing noise. I suspect the problem may be loose main bearings that are allowing leak down. During the overhaul the standard size main bearings were used and they may have been a little loose - e.g. the clearance may have been at the high end of the allowable or just a bit over. Not sure but that is what I suspect. But there may be other things to cause the leak down as well. Hoping someone has some insight. Thanks.

Please Log in or Create an account to join the conversation.

Advertisement
More
4 months 1 week ago #203077 by no_common_sense
Replied by no_common_sense on topic engine rattle on start up
I'm not familiar with that engine, but I'll throw one possibility at you. Try replacing the oil filter. Maybe it's a faulty drain back valve issue.

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #203078 by rahuljones
Replied by rahuljones on topic engine rattle on start up
Which grade oil do you use? How much KMs since the overhaul?

Please Log in or Create an account to join the conversation.

Time to create page: 0.226 seconds