Menu

2007 Accord V6 AC Compressor Issue

Home Forums Stay Dirty Lounge Service and Repair Questions Answered Here 2007 Accord V6 AC Compressor Issue

This topic contains 0 replies, has 1 voice, and was last updated by Chuck H. Chuck Hyppa 4 months ago.

  • Creator
    Topic
  • #962127
    Chuck H.
    Chuck Hyppa
    Participant

    Good afternoon All,

    The AC compressor clutch isn’t engaging. I’ve swapped out the compressor clutch relay with several other relays without success, so I don’t think it’s the relay. The MG Clutch fuse is good, so it isn’t that. I start the car, turn on the AC to try to check power but not getting anything. I’m not 100% sure I’m checking it correctly with my multi-meter. I touch the meter probe to the pin on the electrical connector but it’s not showing any DC voltage, just 0.00. Should I back probe the wire?

    A little back history, a year ago it stopped cooling, took it to the garage and they charged it up and said there is a leak. It worked fine until recently. Now the compressor doesn’t engage when you press the AC button and no air. I bought a can of refrigerant, AC Pro I think? Tried last night to recharge it. Hooked up the hose to the Low side and the gauge on the can read “Low”. Turned on the car to try and put more coolant but again the compressor never engaged and after a quick pull of the trigger on the refrigerant can, it said the system was “full”. I find that hard to believe. Guessing it just filled the line super quick but without the compressor running it’s a false reading.

    So trying to figure this out. Is the compressor not running because the pressure level is too low? Or is the compressor not running because it’s shot and time to replace it? Or, am I not getting power to the compressor? Is there another fuse to check that I’m missing? I couldn’t find one other than the relays and MG Clutch fuse. Can you confirm how to test for power with my meter? Trying to fix it myself. Can’t afford the garage and it’s too hot in Florida in the summer to be without ac.

    I checked for pressure last night by pressing on the Schrader valve but nothing came out. That’s when I tried to recharge as mentioned above. Thanks, Chuck

You must be logged in to reply to this topic.

Loading…