Menu

Ford Escape P0299 code

  • Creator
    Topic
  • #1025145
    Eddie HarperEddie Harper
    Participant

      Hello. About 2 months ago, my 2015 ford escape was losing power when accelerating. There was also white smoke from the exhaust. It was leaking coolant pretty severely, to the point i had to refill it several times. Then the engine light came on, with the p0299 code. I took it in for service. I was quoted 4500 for a turbo replacement. I went to a few other mechanics in my area, and finally settled with a shop that would do it for about 2k with labor and parts. This was a mistake. They installed the turbo halfway, then the mechanic quite, and the owner didn’t have anyone to finish. I had to have it towed to another mechanic to complete the install. I finally get it back. There doesn’t seem to be any coolant leaking anymore, which i don’t get because i was under the impression that a coolant issue wouldn’t be associated with the turbo. It’s fine for a week, but then 6 days later the engine light comes back on with the same code. I took it back to the 2nd mechanic. He checked it over, said he couldn’t see anything wrong with it, no clamps, or hoses or anything seemed out of place. He cleared the engine light. I get it back, then, 6 days later, it comes back on again. That’s where I am right now. Not sure if it actually is the turbo, or could be something else? He suggested maybe replacing the diaphragm, but I’m just guessing at this point, and I don’t know what to do. Any thoughts or suggestions would be greatly appreciated. Thank you.

    • You must be logged in to reply to this topic.
    Loading…