Menu
  • Home
  • Topic
  • Hit Deer 03 CRV. Replaced Radiator etc- No Heat Heat inside & Engine Overheating

Hit Deer 03 CRV. Replaced Radiator etc- No Heat Heat inside & Engine Overheating

Home Forums Stay Dirty Lounge Service and Repair Questions Answered Here Hit Deer 03 CRV. Replaced Radiator etc- No Heat Heat inside & Engine Overheating

Tagged: , , ,

This topic contains 0 replies, has 1 voice, and was last updated by jake allen jake allen 2 weeks ago.

  • Creator
    Topic
  • #987137
    jake allen
    jake allen
    Participant

    The deer bent the front metal bumper mount so much that it pushed into the ac condenser thus smashing into the radiator.

    Replaced w/OEM radiator and condenser, but whilst doing so, i accidentally ripped out 2 connectors from radiator harness and needed a custom connector from amazon to connect 1 of them, as there is no OEM part for this. Link to see custom part RED/BLACK WIRES- Image also below

    Also: After putting back together car is overheating..

    The two connectors that I had to repair:

    “First connector” went to radiator fan on passenger side- i had to glue connector so it wouldn’t come out of connector.
    “Second connector” (in which i think may be culprit) connects to the coolant temp sensor at bottom of radiator. See image at bottom. Btw i used OLD temp sensor from broken radiator, and inserted into the new radiator.

    Would any of this cause the heat not to come on in the car? If not, any ideas?
    

    p.s. running w/o ac coolant as it leaked out.
    

You must be logged in to reply to this topic.

Loading…